We are experiencing a service disruption impacting inbound and outbound calling due to an upstream vendor issue. Our team is working with the vendor to restore service as quickly as possible. Updates will be provided as they become available.

Incident Report for Drips

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 16:54 EST

Investigating

We are currently investigating this issue.
Posted Feb 20, 2026 - 15:53 EST
This incident affected: Voice Platform.